Skip to main content

How to backup and restore GPT header and table / MBR on mac ?

Mac OS X systems use GPT based partition table on a physical hard disk. Sometimes due to disk errors or any other reasons the GPT partition table may get corrupt. In such situations the operating systems restore the GPT table from the secondary GPT header lying at the end of the disk. There are some situations when secondary header is also corrupt then it is very hard to recover the partition schema of that disk. We can take a backup of the GPT table from the mac in the form a device file and can use it to restore back onto disk. 

The GPT table and header of the disk can be backed-up as below :

         $ sudo dd if=/dev/disk0 of=GPT bs=512 count=34

The GPT table and header of the disk can be restored as below :

         $ sudo dd if=GPT of=/dev/disk0 bs=512 count=34



Similarly for MBR disks back up can be taken as below:

         $ dd if=/dev/disk0 of=MBR bs=512 count=1


MBR header can be restored back as :

         $ dd if=MBR of=/dev/disk0

Comments

Popular posts from this blog

How to find firmware or boot ROM version in Mac OS X

Firmware and boot ROM version of your mac can be found in two ways. Way 1 : 1. From "Apple" menu , choose "About This Mac" menu item. 2. Click " More Info " to open "System Profiler" application. 3. Under Contents -> Select Hardware Tree item. On the right side panel Under hardware overview section, we can see Boot ROM Version and SMC (Firmware) Version. Way 2 : Run the below command in terminal to get boot ROM version and SMC(firmware) version : $ system_profiler SPHardwareDataType | grep -i "Version" | awk -F ':' '{print $1 $2}'

How to extract signing certificates from macOS binary files

Code signing is a macOS security technology that you use to certify that an app was created by you. Once an app is signed, the system can detect any change to the app—whether the change is introduced accidentally or by malicious code. As Apple Developer site says ( click here for more details  on code signing) : code signing allows the operating system to: Ensure that a piece of code has not been altered since it was signed.  The system can detect even the smallest change, whether it was intentional (by a malicious attacker, for example) or accidental (as when a file gets corrupted). When a code signature is intact, the system can be sure the code is as the signer intended. Identify code as coming from a specific source (a developer or signer).  The code signature includes cryptographic information that unambiguously points to a particular author. Determine whether code is trustworthy for a specific purpose.  Among other things, a developer can use a code signature to s

What are the useful nvram settings in macOS ?

The OS X boot arguments are useful for troubleshooting problems with system startup and how the system behaves when running. sudo nvram boot-args="-v" :  This command will set the system to always boot to verbose mode, so we do not need to hold Command + V at system startup. sudo nvram boot-args="-x" :  This will set the system to always boot into Safe Mode. sudo nvram boot-args="-s" :  This command will boot the system into single user mode without needing to hold Command-S at system startup. sudo nvram boot-args="iog=0x0"  :   when you close the display but connect the system to an external monitor and keyboard the system will stay awake. After running this command, when connecting an external monitor, the internal display will be disabled, which can be beneficial in some situations such as those where you are mirroring your desktop but wish to run the external display at a higher resolution than your laptop can run. sudo nvram b